[Firefox 技巧]启用不兼容扩展的通用方法

每次 Firefox 出现较大的版本升级,总有几个扩展不兼容。或者想尝试各种测试中的 Beta 版,扩展不兼容是首先要解决的问题。虽然说可以安装 Nightly Tester Tools 来强制启用,但是这个问题根本就不需要安装一个扩展来解决,而且它目前还不兼容 Firefox 4.0。

[Firefox 技巧]启用不兼容扩展的通用方法 1

最简单的办法就是配置一下 about:configFirefox 官方有详细的说明,只需新建一个 Extensions.checkCompatibility 就行了。

该通用方法是:在地址栏输入 about:config,点击右键,选择“新建→布尔”,在弹出窗口输入 extensions.checkCompatibility.<version>,确定之后,选择 false

那么 <version> 究竟该替换成什么呢?请看下面的例子:

  • Firefox 3.6b2 -> extensions.checkCompatibility.3.6b
  • Firefox 3.6pre -> extensions.checkCompatibility.3.6p
  • Firefox 3.6Firefox 3.6.8 -> extensions.checkCompatibility.3.6
  • Firefox 3.7a1 -> extensions.checkCompatibility.3.7a
  • Firefox 4.0b2pre -> extensions.checkCompatibility.4.0b
  • SeaMonkey 2.1a1 -> extensions.checkCompatibility.2.1a

<version> 的规律是:取版本号前三个字符组成的小数 + 1 个字母。

P.S.1 AnyBizSoft PDF to Word 免费中文版发布

P.S.2 Riku 开了个新博客 WOW!Ubuntu,专门介绍 Ubuntu 新闻技巧和软件。

24 Comments

  1. 浓汤 2010/08/14 Reply
  2. 笑眯眯的狗 2010/08/14 Reply
  3. 紫云飞 2010/08/14 Reply
  4. 术士 2010/08/14 Reply
  5. 破船@poboat 2010/08/14 Reply
  6. 煋人 2010/08/14 Reply
  7. 187j3x1 2010/08/14 Reply
  8. ryan 2010/08/14 Reply
  9. 天净杀 2010/08/14 Reply
    • sfufoet 2010/08/14 Reply
  10. keeds 2010/08/14 Reply
  11. Joystyle 2010/08/14 Reply
  12. wsky 2010/08/14 Reply
  13. realnabarl 2010/08/14 Reply
  14. 刘丽 2010/08/15 Reply
    • sfufoet 2010/08/15 Reply
  15. zhayo 2010/08/15 Reply
    • sfufoet 2010/08/15 Reply
  16. YY 2010/08/15 Reply
  17. duskash 2010/08/16 Reply
  18. Mucid 2010/08/18 Reply
  19. iuv 2010/08/20 Reply
  20. 皇家元林 2010/08/23 Reply
  21. EVAngel 2010/09/20 Reply

Leave a Reply